#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?msx) " & @CRLF & _
"(^http:\/\/www\. .+$) " & @CRLF & _
"(?= .* \1) "
Local $sString = "http://www.link1.com" & @CRLF & _
"http://www.link2.com" & @CRLF & _
"http://www.link3.com" & @CRLF & _
"http://www.link4.com" & @CRLF & _
"http://www.link1.com" & @CRLF & _
"http://www.link2.com" & @CRLF & _
"http://www.link4.com" & @CRLF & _
"http://www.link4.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")