using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?msx)
(^http:\/\/www\. .+$)
(?= .* \1) ";
string input = @"http://www.link1.com
http://www.link2.com
http://www.link3.com
http://www.link4.com
http://www.link1.com
http://www.link2.com
http://www.link4.com
http://www.link4.com";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}