import re
regex = re.compile((r"(?msx) \n"
r"(^http:\/\/www\. .+$) \n"
r"(?= .* \1) "))
test_str = ("http://www.link1.com\n"
"http://www.link2.com\n"
"http://www.link3.com\n"
"http://www.link4.com\n"
"http://www.link1.com\n"
"http://www.link2.com\n"
"http://www.link4.com\n"
"http://www.link4.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")