package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?msx)
(^http:\/\/www\. .+$)
(?= .* \1) `)
var str = `http://www.link1.com
http://www.link2.com
http://www.link3.com
http://www.link4.com
http://www.link1.com
http://www.link2.com
http://www.link4.com
http://www.link4.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}