re = /(?msx)
(^http:\/\/www\. .+$)
(?= .* \1) /
str = 'http://www.link1.com
http://www.link2.com
http://www.link3.com
http://www.link4.com
http://www.link1.com
http://www.link2.com
http://www.link4.com
http://www.link4.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end