use strict;
my $str = 'http://www.link1.com
http://www.link2.com
http://www.link3.com
http://www.link4.com
http://www.link1.com
http://www.link2.com
http://www.link4.com
http://www.link4.com';
my $regex = qr/(?msx)
(^http:\/\/www\. .+$)
(?= .* \1) /p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}