# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<(?![^>]*<)/</gi;t' <<< "<!DOCTYPE html>
...
<anytag>
<h1>This is the less than < symbol. </h1>
<h1>This is the less than or equal to <= symbol. </h1>
</anytag>"