const regex = /<(?![^>]*<)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(?![^>]*<)', 'gi')
const str = `<!DOCTYPE html>
...
<anytag>
<h1>This is the less than < symbol. </h1>
<h1>This is the less than or equal to <= symbol. </h1>
</anytag>`;
const subst = `<`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);