use strict;
my $str = '<!DOCTYPE html>
...
<anytag>
<h1>This is the less than < symbol. </h1>
<h1>This is the less than or equal to <= symbol. </h1>
</anytag>';
my $regex = qr/<(?![^>]*<)/ip;
my $subst = '<';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";