re = /<(?![^>]*<)/i
str = '<!DOCTYPE html>
...
<anytag>
<h1>This is the less than < symbol. </h1>
<h1>This is the less than or equal to <= symbol. </h1>
</anytag>'
subst = '<'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result