#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[^\S]*(\w*)(?:\s*)(?:\([^()]*\))*"
Local $sString = "John (Juan, Jonathan, Jon, Jonny) James Doe (born on January 1, 1900) (Canada)"
Local $sSubst = "$1 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)