$re = '/[^\S]*(\w*)(?:\s*)(?:\([^()]*\))*/m';
$str = 'John (Juan, Jonathan, Jon, Jonny) James Doe (born on January 1, 1900) (Canada)';
$subst = "$1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;