import Foundation
let pattern = #"[^\S]*(\w*)(?:\s*)(?:\([^()]*\))*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"John (Juan, Jonathan, Jon, Jonny) James Doe (born on January 1, 1900) (Canada)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)