package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\S]*(\w*)(?:\s*)(?:\([^()]*\))*`)
var str = `John (Juan, Jonathan, Jon, Jonny) James Doe (born on January 1, 1900) (Canada)`
var substitution = "$1 "
fmt.Println(re.ReplaceAllString(str, substitution))
}