re = /[^\S]*(\w*)(?:\s*)(?:\([^()]*\))*/m
str = 'John (Juan, Jonathan, Jon, Jonny) James Doe (born on January 1, 1900) (Canada)'
subst = '$1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result