// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^\S]*(\w*)(?:\s*)(?:\([^()]*\))*").unwrap();
let string = "John (Juan, Jonathan, Jon, Jonny) James Doe (born on January 1, 1900) (Canada)";
let substitution = "$1 ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}