using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\S]*(\w*)(?:\s*)(?:\([^()]*\))*";
string substitution = @"$1 ";
string input = @"John (Juan, Jonathan, Jon, Jonny) James Doe (born on January 1, 1900) (Canada)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}