use strict;
my $str = 'John (Juan, Jonathan, Jon, Jonny) James Doe (born on January 1, 1900) (Canada)';
my $regex = qr/[^\S]*(\w*)(?:\s*)(?:\([^()]*\))*/mp;
my $subst = '$1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";