#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\\\\u([^_]+)"
Local $sString = "Jos\\u00e9_A\\u002e_Santos" & @CRLF & _
""
Local $sSubst = "\\$$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)