import re
regex = re.compile(r"\\\\u([^_]+)")
test_str = ("Jos\\\\u00e9_A\\\\u002e_Santos\n")
subst = "\\\\$$1"
result = regex.sub(subst, test_str)
if result:
print(result)