use strict;
my $str = 'Jos\\\\u00e9_A\\\\u002e_Santos
';
my $regex = qr/\\\\u([^_]+)/p;
my $subst = '\\\\$$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";