$re = '/\\\\\\\\u([^_]+)/';
$str = 'Jos\\\\u00e9_A\\\\u002e_Santos
';
$subst = "\\$$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;