// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\\\\u([^_]+)").unwrap();
let string = "Jos\\\\u00e9_A\\\\u002e_Santos
";
let substitution = "\\\\$$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}