using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\\\u([^_]+)";
string substitution = @"\\$$1";
string input = @"Jos\\u00e9_A\\u002e_Santos
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}