using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"~\/v4\/orgs\/\w{8}-\w{4}-\w{4}-\w{4}-\w{12}\/reports";
string input = @"/v4/orgs/ac7ece39-3506-452c-befc-b355b9cf8c0f/reports";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}