import re
regex = re.compile(r"~\/v4\/orgs\/\w{8}-\w{4}-\w{4}-\w{4}-\w{12}\/reports", flags=re.IGNORECASE)
test_str = "/v4/orgs/ac7ece39-3506-452c-befc-b355b9cf8c0f/reports"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")