import Foundation
let pattern = #"~\/v4\/orgs\/\w{8}-\w{4}-\w{4}-\w{4}-\w{12}\/reports"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"/v4/orgs/ac7ece39-3506-452c-befc-b355b9cf8c0f/reports"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)