package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)~\/v4\/orgs\/\w{8}-\w{4}-\w{4}-\w{4}-\w{12}\/reports`)
var str = `/v4/orgs/ac7ece39-3506-452c-befc-b355b9cf8c0f/reports`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}