import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "~\\/v4\\/orgs\\/\\w{8}-\\w{4}-\\w{4}-\\w{4}-\\w{12}\\/reports";
final String string = "/v4/orgs/ac7ece39-3506-452c-befc-b355b9cf8c0f/reports";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}