const regex = /~\/v4\/orgs\/\w{8}-\w{4}-\w{4}-\w{4}-\w{12}\/reports/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('~\\\/v4\\\/orgs\\\/\\w{8}-\\w{4}-\\w{4}-\\w{4}-\\w{12}\\\/reports', 'ig')
const str = `/v4/orgs/ac7ece39-3506-452c-befc-b355b9cf8c0f/reports`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}