// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)~\/v4\/orgs\/\w{8}-\w{4}-\w{4}-\w{4}-\w{12}\/reports").unwrap();
let string = "/v4/orgs/ac7ece39-3506-452c-befc-b355b9cf8c0f/reports";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}