re = /~\/v4\/orgs\/\w{8}-\w{4}-\w{4}-\w{4}-\w{12}\/reports/i
str = '/v4/orgs/ac7ece39-3506-452c-befc-b355b9cf8c0f/reports'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end