using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*THIRD.*(?:SECOND|FIRST)) # SECOND or FIRST cannot appear after THIRD
(?!.*SECOND.*FIRST) # SECOND cannot appear before FIRST
(?!.*THIRD.*THIRD)
(?!.*SECOND.*SECOND)
(?!.*FIRST.*FIRST)
(?=.*FIRST).*";
string input = @"FIRST
FIRST SECOND
FIRST SECOND THIRD
SECOND THIRD FIRST
SECOND FIRST THIRD
THIRD SECOND FIRST
FIRST FIRST
SECOND FIRST THIRD
FIRST SECOND SECOND
The word FIRST is mandatory ; it can appear only once
The word SECOND can appear zero or one time
The word THIRD can appear zero or one time
Order: FIRST, then SECOND then THIRD";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}