import Foundation
let pattern = ##"""
^(?!.*THIRD.*(?:SECOND|FIRST)) # SECOND or FIRST cannot appear after THIRD
(?!.*SECOND.*FIRST) # SECOND cannot appear before FIRST
(?!.*THIRD.*THIRD)
(?!.*SECOND.*SECOND)
(?!.*FIRST.*FIRST)
(?=.*FIRST).*
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
FIRST
FIRST SECOND
FIRST SECOND THIRD
SECOND THIRD FIRST
SECOND FIRST THIRD
THIRD SECOND FIRST
FIRST FIRST
SECOND FIRST THIRD
FIRST SECOND SECOND
The word FIRST is mandatory ; it can appear only once
The word SECOND can appear zero or one time
The word THIRD can appear zero or one time
Order: FIRST, then SECOND then THIRD
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)