const regex = /^(?!.*THIRD.*(?:SECOND|FIRST)) # SECOND or FIRST cannot appear after THIRD
(?!.*SECOND.*FIRST) # SECOND cannot appear before FIRST
(?!.*THIRD.*THIRD)
(?!.*SECOND.*SECOND)
(?!.*FIRST.*FIRST)
(?=.*FIRST).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*THIRD.*(?:SECOND|FIRST)) # SECOND or FIRST cannot appear after THIRD
(?!.*SECOND.*FIRST) # SECOND cannot appear before FIRST
(?!.*THIRD.*THIRD)
(?!.*SECOND.*SECOND)
(?!.*FIRST.*FIRST)
(?=.*FIRST).*', 'gm')
const str = `FIRST
FIRST SECOND
FIRST SECOND THIRD
SECOND THIRD FIRST
SECOND FIRST THIRD
THIRD SECOND FIRST
FIRST FIRST
SECOND FIRST THIRD
FIRST SECOND SECOND
The word FIRST is mandatory ; it can appear only once
The word SECOND can appear zero or one time
The word THIRD can appear zero or one time
Order: FIRST, then SECOND then THIRD`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}