import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*THIRD.*(?:SECOND|FIRST)) # SECOND or FIRST cannot appear after THIRD\n"
+ "(?!.*SECOND.*FIRST) # SECOND cannot appear before FIRST\n"
+ "(?!.*THIRD.*THIRD) \n"
+ "(?!.*SECOND.*SECOND)\n"
+ "(?!.*FIRST.*FIRST)\n"
+ "(?=.*FIRST).*";
final String string = "FIRST\n"
+ "FIRST SECOND\n"
+ "FIRST SECOND THIRD\n"
+ "SECOND THIRD FIRST\n"
+ "SECOND FIRST THIRD\n"
+ "THIRD SECOND FIRST\n"
+ "FIRST FIRST\n"
+ " SECOND FIRST THIRD\n"
+ "FIRST SECOND SECOND\n"
+ "The word FIRST is mandatory ; it can appear only once\n"
+ "The word SECOND can appear zero or one time\n"
+ "The word THIRD can appear zero or one time\n"
+ "Order: FIRST, then SECOND then THIRD";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}