import re
regex = re.compile(r"""
^(?!.*THIRD.*(?:SECOND|FIRST)) # SECOND or FIRST cannot appear after THIRD
(?!.*SECOND.*FIRST) # SECOND cannot appear before FIRST
(?!.*THIRD.*THIRD)
(?!.*SECOND.*SECOND)
(?!.*FIRST.*FIRST)
(?=.*FIRST).*
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("FIRST\n"
"FIRST SECOND\n"
"FIRST SECOND THIRD\n"
"SECOND THIRD FIRST\n"
"SECOND FIRST THIRD\n"
"THIRD SECOND FIRST\n"
"FIRST FIRST\n"
" SECOND FIRST THIRD\n"
"FIRST SECOND SECOND\n"
"The word FIRST is mandatory ; it can appear only once\n"
"The word SECOND can appear zero or one time\n"
"The word THIRD can appear zero or one time\n"
"Order: FIRST, then SECOND then THIRD")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")