$re = '/^(?!.*THIRD.*(?:SECOND|FIRST)) # SECOND or FIRST cannot appear after THIRD
(?!.*SECOND.*FIRST) # SECOND cannot appear before FIRST
(?!.*THIRD.*THIRD)
(?!.*SECOND.*SECOND)
(?!.*FIRST.*FIRST)
(?=.*FIRST).*/mx';
$str = 'FIRST
FIRST SECOND
FIRST SECOND THIRD
SECOND THIRD FIRST
SECOND FIRST THIRD
THIRD SECOND FIRST
FIRST FIRST
SECOND FIRST THIRD
FIRST SECOND SECOND
The word FIRST is mandatory ; it can appear only once
The word SECOND can appear zero or one time
The word THIRD can appear zero or one time
Order: FIRST, then SECOND then THIRD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);