# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?>[^\w\n]*(\w++)(?=.*\R(\2?+[^\w\n]*\1\b)))+[^\w\n]*\R(?=\2[^\w\n]*$)//gmi;t' <<< "foo bar baz
foo bar baz
foo bar baz
a
a b
a b c
a b
a"