import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?>[^\\w\\n]*(\\w++)(?=.*\\R(\\2?+[^\\w\\n]*\\1\\b)))+[^\\w\\n]*\\R(?=\\2[^\\w\\n]*$)";
final String string = "foo bar baz\n"
+ "foo bar baz\n"
+ "foo bar baz\n\n"
+ "a\n"
+ "a b\n"
+ "a b c\n"
+ "a b\n"
+ "a";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}