const regex = /^(?>[^\w\n]*(\w++)(?=.*\R(\2?+[^\w\n]*\1\b)))+[^\w\n]*\R(?=\2[^\w\n]*$)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?>[^\\w\\n]*(\\w++)(?=.*\\R(\\2?+[^\\w\\n]*\\1\\b)))+[^\\w\\n]*\\R(?=\\2[^\\w\\n]*$)', 'gmi')
const str = `foo bar baz
foo bar baz
foo bar baz
a
a b
a b c
a b
a`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);