re = /^(?>[^\w\n]*(\w++)(?=.*\R(\2?+[^\w\n]*\1\b)))+[^\w\n]*\R(?=\2[^\w\n]*$)/mi
str = 'foo bar baz
foo bar baz
foo bar baz
a
a b
a b c
a b
a'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result