#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)^(?>[^\w\n]*(\w++)(?=.*\R(\2?+[^\w\n]*\1\b)))+[^\w\n]*\R(?=\2[^\w\n]*$)"
Local $sString = "foo bar baz" & @CRLF & _
"foo bar baz" & @CRLF & _
"foo bar baz" & @CRLF & _
"" & @CRLF & _
"a" & @CRLF & _
"a b" & @CRLF & _
"a b c" & @CRLF & _
"a b" & @CRLF & _
"a"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)