import re
regex = re.compile(r"^(?>[^\w\n]*(\w++)(?=.*\R(\2?+[^\w\n]*\1\b)))+[^\w\n]*\R(?=\2[^\w\n]*$)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("foo bar baz\n"
"foo bar baz\n"
"foo bar baz\n\n"
"a\n"
"a b\n"
"a b c\n"
"a b\n"
"a")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)