$re = '/^(?>[^\w\n]*(\w++)(?=.*\R(\2?+[^\w\n]*\1\b)))+[^\w\n]*\R(?=\2[^\w\n]*$)/mi';
$str = 'foo bar baz
foo bar baz
foo bar baz
a
a b
a b c
a b
a';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;