use strict;
my $str = 'foo bar baz
foo bar baz
foo bar baz
a
a b
a b c
a b
a';
my $regex = qr/^(?>[^\w\n]*(\w++)(?=.*\R(\2?+[^\w\n]*\1\b)))+[^\w\n]*\R(?=\2[^\w\n]*$)/mip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";