#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)function (.+)\(.*\)\s*\{"
Local $sString = " function example()" & @CRLF & _
" {" & @CRLF & _
" " & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" function example2()" & @CRLF & _
" {" & @CRLF & _
"" & @CRLF & _
" }"
Local $sSubst = "$& console.log("$1()");"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)