const regex = /function (.+)\(.*\)\s*\{/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('function (.+)\\(.*\\)\\s*\\{', 'gm')
const str = ` function example()
{
}
function example2()
{
}`;
const subst = `$& console.log("$1()");`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);