re = /function (.+)\(.*\)\s*\{/m
str = ' function example()
{
}
function example2()
{
}'
subst = '$& console.log("$1()");'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result