use strict;
my $str = ' function example()
{
}
function example2()
{
}';
my $regex = qr/function (.+)\(.*\)\s*\{/mp;
my $subst = '$& console.log("$1()");';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";